Some customers might experience an error message when accessing the 'Supplier Onboarding' page.

Incident Report for Eftsure

Resolved

Dear Eftsure customers,

The earlier issue affecting the 'Supplier Onboarding' page for certain users has now been fully resolved.

We appreciate your patience and understanding throughout the process. If you have any further questions or notice anything unusual, please don’t hesitate to reach out to our support team.

Thank you for bearing with us.
Sincerely,
Posted Jul 15, 2025 - 21:53 AEST

Identified

Dear Eftsure Customers,

Please be aware that some users may encounter an "Oops" error message when attempting to access the Supplier Onboarding page within the customer portal.

Our engineering team has identified the root cause and is actively working on deploying a fix. Please be assured that resolving this issue is a top priority, and we will keep you informed with any significant updates.

Thank you for your patience and understanding.

Sincerely,
The Eftsure Team
Posted Jul 15, 2025 - 17:49 AEST
This incident affected: Customer Portal (Supplier Onboarding).