Eftsure Portal Outage

Incident Report for Eftsure

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 11:14 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2026 - 08:52 AEDT

Investigating

We are currently investigating this issue.
Posted Feb 25, 2026 - 08:30 AEDT
This incident affected: Supplier Functionality (Supplier Portal/ Forms, Supplier Mailout), Bank Overlay, APIs, and Customer Portal (Dashboard, Supplier Onboarding, Supplier Management, Payments Review, Reports, Document Library, Help).