Intermittent Service Disruption

Incident Report for Eftsure

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 18:19 AEDT

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 18:18 AEDT

Update

This issue has been resolved and our systems are operating normally again. Thank you for your understanding and patience with this. If you have further concerns, please do not hesitate to contact our support team.
Posted Oct 21, 2025 - 18:17 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 15:22 AEDT

Investigating

We are currently investigating this issue.
Posted Oct 21, 2025 - 13:30 AEDT
This incident affected: Supplier Functionality (Supplier Portal/ Forms, Supplier Mailout), Bank Overlay, APIs, and Customer Portal (Dashboard, Supplier Onboarding, Supplier Management, Payments Review, Reports, Document Library).