Issue with Self-Certify
Incident Report for Eftsure
Resolved
This incident is resolved and Self-Certify feature is working again.
Posted Jun 07, 2023 - 11:27 AEST
Investigating
There is an issue with self-certifying suppliers from the portal. We are currently investigating the issue and will publish a fix at the earliest. You'll be able to complete your self-certifications once the incident is resolved.
Posted Jun 07, 2023 - 11:02 AEST
This incident affected: Customer Portal (Supplier Management).