The earlier issue affecting the customer portal has been fully resolved.
We appreciate your patience and understanding throughout the process. If you have any further questions or notice anything unusual, please don’t hesitate to reach out to our support team.
Sincerely, The Eftsure Team
Posted Oct 28, 2025 - 18:25 AEDT
Identified
Dear Eftsure customers,
Our engineering team has identified the root cause and is currently testing prior to deploying a fix. We will continue to keep you informed as we make progress.
Sincerely, The Eftsure Team
Posted Oct 28, 2025 - 15:57 AEDT
Investigating
Dear Eftsure customers,
We are currently experiencing an issue with the 'Supplier Management', where some users are not able to access it and are getting an 'Oops Something Went Wrong' message. Our engineering team is actively investigating the root cause and working on a fix as quickly as possible.
We will keep you informed as we make progress and provide updates as they become available. We apologise for the inconvenience and appreciate your patience.
Sincerely, The Eftsure Team
Posted Oct 28, 2025 - 15:24 AEDT
This incident affected: Customer Portal (Supplier Management).