Technical Issue when using default template for NZ suppliers when using the 'Payment Review'.

Incident Report for Eftsure

Resolved

Dear Eftsure customer,

Just letting you know that this issue has been fixed now and the NZ Payment review is up and running fine now.

Thank you for your patience.
Posted Mar 21, 2025 - 11:41 AEDT

Identified

Dear Eftsure Customer,

We have identified a technical issue with the NZ payment review when using our default template. Our development team are looking into it with utmost priority and a fix should be deployed very soon.

Apologies for the inconvenience and thank you for bearing with us.
Posted Mar 20, 2025 - 13:16 AEDT
This incident affected: Customer Portal (Payments Review).