We are currently experiencing a technical issue with verification requests not going out

Incident Report for Eftsure

Resolved

We have identified the cause and our engineers have created a hotfix for the issue
Posted Apr 15, 2025 - 20:47 AEST

Investigating

Dear Eftsure customer,

We are currently experiencing a technical issue with the verification request. When triggering a verification request, it is not going out, or it is already showing a pending onboarding when no verification email went out.

Our development team are looking into it with our utmost priority, and once they isolate the issue, they will be able to work and deploy a fix for it.

Thank you for your patience and cooperation.

The Eftsure Team.
Posted Apr 15, 2025 - 16:46 AEST
This incident affected: Customer Portal (Supplier Management).