Scheduled maintenance
Incident Report for Eftsure
Resolved
This incident has been resolved.
Posted Dec 10, 2023 - 23:07 AEDT
Update
We are continuing to investigate this issue.
Posted Dec 10, 2023 - 21:39 AEDT
Investigating
We are currently investigating this issue.
Posted Dec 10, 2023 - 21:38 AEDT
This incident affected: Supplier Functionality (Supplier Portal/ Forms, Supplier Mailout), Bank Overlay, APIs, and Customer Portal (Dashboard, Supplier Onboarding, Supplier Management, Payments Review, Reports, Document Library, Help).