Portal Performance
Incident Report for Eftsure
Resolved
This incident has been resolved.
Posted Jun 21, 2023 - 12:03 AEST
Update
We are continuing to investigate this issue.
Posted Jun 21, 2023 - 09:48 AEST
Investigating
We are currently investigating an issue impacting the overall speed and performance of the portal.
Posted Jun 21, 2023 - 09:48 AEST
This incident affected: Supplier Functionality (Supplier Portal/ Forms) and Customer Portal (Dashboard, Supplier Onboarding, Supplier Management, Payments Review, Reports, Document Library, Help).