Portal Update
Incident Report for Eftsure
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 10:05 AEST
Identified
The Eftsure Portal is currently being updated. We will be back online soon
Posted Apr 06, 2023 - 09:50 AEST
Investigating
We are currently investigating this issue.
Posted Apr 06, 2023 - 09:44 AEST
This incident affected: Supplier Functionality (Supplier Portal/ Forms, Supplier Mailout), Bank Overlay, APIs, and Customer Portal (Dashboard, Supplier Onboarding, Supplier Management, Payments Review, Reports, Document Library, Help).