ABR to be refreshed so that GST status is up to date
Incident Report for Eftsure
Resolved
This issue has been resolved now and GST status is showing as expected.
Posted Aug 29, 2024 - 20:55 AEST
Investigating
Please be aware that we are working on the refresh with the ABR website so that the GST status is up to date.
Posted Aug 27, 2024 - 17:04 AEST
This incident affected: Customer Portal (Supplier Onboarding, Supplier Management).