Some NZ verified suppliers are showing as unverified
Incident Report for Eftsure
Resolved
Our dev team has deployed a fix and now the NZ suppliers are showing as verified.
Posted Nov 15, 2023 - 16:53 AEDT
Investigating
Dear Eftsure customers,

We have identified an issue where some verified NZ suppliers are now showing as unverified.

Our development team is investigating it with utmost priority to resolve it.

Thank you for your patience and our sincere apologies for the inconvenience caused.
Posted Nov 15, 2023 - 15:50 AEDT
This incident affected: Customer Portal (Supplier Management).