Supplier Portal scheduled maintenance today from 6pm Sydney time for ~30mins

Incident Report for Eftsure

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 09:43 AEDT

Investigating

Dear Customers and Suppliers,

We would like to inform you that scheduled maintenance will be performed on the Supplier Portal on 19/03/2025 from 6pm for ~30mins. During this time, the Supplier Portal will be temporarily unavailable.

We apologise for any inconvenience this may cause and appreciate your understanding.

Thank you for your cooperation.

Best regards,
The Eftsure Team
Posted Mar 19, 2025 - 13:19 AEDT
This incident affected: Supplier Functionality (Supplier Portal/ Forms).